PHP is among the most widely used open-source programming languages. It’s rather popular as it is free software, which can be used to set up responsive sites like social networking websites, shopping portals or e-teaching portals rather than static HTML sites. A PHP module must be activated on the server where a PHP-driven website is hosted so that its PHP code can be read. As there are no license charges for this kind of module and the language itself provides unlimited possibilities for the web applications that you set up, there are hundreds of millions of PHP-powered sites. Plus, there are loads of PHP-based scripts, which you can use for your sites without the need to have any programming skills. As there are a couple of versions of PHP, you have to confirm that the same exact version that you used while building your site is activated on the server too.
PHP 4, PHP 5 and PHP 7 Support in Cloud Website Hosting
Our cloud website hosting servers support different versions of PHP, so your sites will run properly no matter if your PHP-based scripts are out of date. We accept the fact that an old website does not inevitably imply a vulnerable one as you may have implemented a lot of code modifications. This is why we support PHP 4, PHP 5 and PHP 7 and you can select which version will be enabled for your shared web hosting account. The version can be changed with just one mouse click via your Hepsia Control Panel and the new settings will take effect instantly. In case you wish to run both newer and older scripts, there’s even a possibility to use a different PHP version for each of your domains at the same time.
PHP 4, PHP 5 and PHP 7 Support in Semi-dedicated Hosting
Even in case your websites were built with an older version of PHP, you’ll be able to host them in a semi-dedicated server account from us, as we support different versions running simultaneously on our servers and each one of them can be enabled for your account with no more than a click through our in-house developed Hepsia hosting Control Panel. Apart from the most recent PHP 7, we also offer support for 5.2, 5.3 and the older PHP 4, which has already been abandoned by the vast majority of web hosting vendors, but we strongly believe that you shouldn’t be forced to modify a website that took years to create, since older script language syntax does not automatically suggest safety flaws. Just the opposite, a properly maintained website using PHP 4 can be more secure than an improperly maintained one using PHP 5. For your convenience, we will also provide you with the possibility to set a different version for each site within your account.